Home Run simple console application made with VS2010 framework 4.0 in a XP computer with framework 1.1
Reply: 1

Run simple console application made with VS2010 framework 4.0 in a XP computer with framework 1.1

Ricardo Olivo Poletti
1#
Ricardo Olivo Poletti Published in 2017-12-07 16:38:38Z

The application is quite simple, it just deletes some local files every configured time period, there is no linq no nothing "new" in the code. If I change the target framework to 2.0 it works well in my computer, but VS2010 doesnt have .net 1.1 as an available target framework.

Is it possible to have it run in an old xp computer that has framework 1.1 (I dont have acces to the computer, cant change its framework). The question is, is there something I can do (in the config file or sln file?) so that it can run in framework 1.1, or do I have to get VS2003 to recreate the console app using 1.1 framework?

Thanks in advance.

Alexei Levenkov
2#
Alexei Levenkov Reply to 2017-12-07 16:47:14Z

No, there is nothing you can do to get 2.0 or 4.x .Net executable to run with 1.x framework.

You need to compile against 1.x. If you have old VS 2003 around you can use it to recompile solution. If you can't find it - you still can use command line tools (see Visual Studio 2005 and .Net framework 1.1 for some info). For simple project with just CS files using csc on target machine to compile the tool from sources may be the easiest route.

You need to login account before you can post.

About| Privacy statement| Terms of Service| Advertising| Contact us| Help| Sitemap|
Processed in 0.329656 second(s) , Gzip On .

© 2016 Powered by mzan.com design MATCHINFO