Home Is there a version of Grails targeted to run on Java 9?
Reply: 0

Is there a version of Grails targeted to run on Java 9?

mcam11
1#
mcam11 Published in 2018-01-04 18:12:55Z

I tried running my Grails 3.3.2 application on Java 9 and for the most part the application worked. Mail (using this plugin: org.grails.plugins:mail:2.0.0), however, doesn't work, so cannot reset password, for example.

Attempting to send mail results in this error:

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'mailService': Invocation of init method failed; nested exception is java.lang.IllegalArgumentException

I believe the issue is with Spring Boot and not the plugin itself. It seems there is a problem with bean creation and Java 9 that Spring Boot addresses is their 2.x version (Grails 3.3.2 runs on Spring Boot 1.5.x).

Just wondering what the time frame is for Grails and Java 9. Thanks!

You need to login account before you can post.

About| Privacy statement| Terms of Service| Advertising| Contact us| Help| Sitemap|
Processed in 0.331649 second(s) , Gzip On .

© 2016 Powered by mzan.com design MATCHINFO