Home blueprint failed to installed the new version HDP - 2.6.3 on new version 2.6.x
Reply: 0

blueprint failed to installed the new version HDP - 2.6.3 on new version 2.6.x

enodmilvado
1#
enodmilvado Published in 2018-01-12 14:20:38Z

we installed from scratch the HDP version - HDP - 2.6.3 & ambari 2.6.x

our environment include 3 masters machines and 2 workers machines ( machines are redhat version 7.3 )

by using the following HDP & ambari kits

HDP-2.6.3.0-centos7-rpm.tar.gz

ambari-2.6.0.0-centos7.tar.gz

when installation completed , we see that installation failed on blueprint stage

and from the ambari-server log we can see the warning in attachment ( ambari-server log )

not clear why blueprint installation push the repository:

ambari-hdp-1.repo under /etc/yum.repol.d ( in version HDP-2.6.0.3 this repository not added to /etc/yum/repo.d )

second when we type hdp-select , we get some errors ( see attachment hdp-select output )

please advice what HDP 2.6.3 blueprint failed , ? because we use exactly the same installation scripts on the previos HDP version ( previous version - HDP-2.6.0.3 installed successfully hundred times )

see please attachment hdp-select output and ambari-server log output

11 Jan 2018 21:25:50,010  WARN [Stack Version Loading Thread] RepoVdfCallable:142 - Could not load version definition for HDP-2.6 identified by http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.6.4.0/HDP-2.6.4.0-91.xml. null
javax.xml.bind.UnmarshalException
 - with linked exception:
[org.xml.sax.SAXParseException; lineNumber: 54; columnNumber: 15; cvc-complex-type.2.4.d: Invalid content was found starting with element 'tags'. No child element is expected at this point.]
        at com.sun.xml.bind.v2.runtime.unmarshaller.UnmarshallerImpl.handleStreamException(UnmarshallerImpl.java:431)
        at com.sun.xml.bind.v2.runtime.unmarshaller.UnmarshallerImpl.unmarshal0(UnmarshallerImpl.java:368)
        at com.sun.xml.bind.v2.runtime.unmarshaller.UnmarshallerImpl.unmarshal(UnmarshallerImpl.java:338)
        at org.apache.ambari.server.state.repository.VersionDefinitionXml.load(VersionDefinitionXml.java:442)
        at org.apache.ambari.server.state.repository.VersionDefinitionXml.load(VersionDefinitionXml.java:395)
        at org.apache.ambari.server.state.stack.RepoVdfCallable.timedVDFLoad(RepoVdfCallable.java:154)
        at org.apache.ambari.server.state.stack.RepoVdfCallable.mergeDefinitions(RepoVdfCallable.java:136)
        at org.apache.ambari.server.state.stack.RepoVdfCallable.call(RepoVdfCallable.java:79)
        at org.apache.ambari.server.state.stack.RepoVdfCallable.call(RepoVdfCallable.java:41)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Caused by: org.xml.sax.SAXParseException; lineNumber: 54; columnNumber: 15; cvc-complex-type.2.4.d: Invalid content was found starting with element 'tags'. No child element is expected at this point.
        at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:203)
        at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.error(ErrorHandlerWrapper.java:134)



more ambari-hdp-1.repo ( this repo not created on the previos version )
[HDP-2.6-repo-1]
name=HDP-2.6-repo-1
baseurl=http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.6.0.3


path=/
enabled=1
gpgcheck=0
[HDP-UTILS-1.1.0.21-repo-1]
name=HDP-UTILS-1.1.0.21-repo-1
baseurl=http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.21/repos/centos7


path=/
enabled=1
gpgcheck=0


















hdp-select
accumulo-client - None
accumulo-gc - None
accumulo-master - None
accumulo-monitor - None
accumulo-tablet - None
accumulo-tracer - None
atlas-client - None
atlas-server - None
beacon - None
beacon-client - None
beacon-server - None
druid-broker - None
druid-coordinator - None
druid-historical - None
druid-middlemanager - None
druid-overlord - None
druid-router - None
druid-superset - None
falcon-client - None
falcon-server - None
flume-server - None
hadoop-client - 2.6.0.3-8
hadoop-hdfs-client - 2.6.0.3-8
hadoop-hdfs-datanode - 2.6.0.3-8
hadoop-hdfs-journalnode - 2.6.0.3-8
hadoop-hdfs-namenode - 2.6.0.3-8
hadoop-hdfs-nfs3 - 2.6.0.3-8
hadoop-hdfs-portmap - 2.6.0.3-8
hadoop-hdfs-secondarynamenode - 2.6.0.3-8
hadoop-hdfs-zkfc - 2.6.0.3-8
hadoop-httpfs - None
hadoop-mapreduce-client - 2.6.0.3-8
hadoop-mapreduce-historyserver - 2.6.0.3-8
hadoop-yarn-client - 2.6.0.3-8
hadoop-yarn-nodemanager - 2.6.0.3-8
hadoop-yarn-resourcemanager - 2.6.0.3-8
hadoop-yarn-timelineserver - 2.6.0.3-8
hbase-client - None
hbase-master - None
hbase-regionserver - None
hive-client - 2.6.0.3-8
hive-metastore - 2.6.0.3-8
hive-server2 - 2.6.0.3-8
hive-server2-hive2 - None
hive-webhcat - None
Traceback (most recent call last):
  File "/usr/bin/hdp-select", line 438, in <module>
    listPackages(getPackages("all"))
  File "/usr/bin/hdp-select", line 257, in listPackages
    os.path.basename(os.path.dirname(os.readlink(linkname))))
OSError: [Errno 22] Invalid argument: '/usr/hdp/current/kafka-broker'
You need to login account before you can post.

About| Privacy statement| Terms of Service| Advertising| Contact us| Help| Sitemap|
Processed in 0.311481 second(s) , Gzip On .

© 2016 Powered by mzan.com design MATCHINFO