Home Oreo disabling autofill lint security error
Reply: 0

Oreo disabling autofill lint security error

Canberk Ozcelik
1#
Canberk Ozcelik Published in 2018-02-14 08:59:12Z

I'm doing kind of a code cleanup and using Android Studio's Inspection/Analyze feature, for the following line:

getWindow().getDecorView().setImportantForAutofill(android.view.View.IMPORTANT_FOR_AUTOFILL_NO_EXCLUDE_DESCENDANTS);

it's yelling as "Android Lint: Security Incorrect constant", ridiculously like:

Must be one of: android.view.View.IMPORTANT_FOR_AUTOFILL_AUTO, android.view.View.IMPORTANT_FOR_AUTOFILL_YES, android.view.View.IMPORTANT_FOR_AUTOFILL_NO, android.view.View.IMPORTANT_FOR_AUTOFILL_YES_EXCLUDE_DESCENDANTS, android.view.View.IMPORTANT_FOR_AUTOFILL_NO_EXCLUDE_DESCENDANTS

Is this some sort of known bugs of Android, do yo have any idea or see that before?

You need to login account before you can post.

About| Privacy statement| Terms of Service| Advertising| Contact us| Help| Sitemap|
Processed in 0.297497 second(s) , Gzip On .

© 2016 Powered by mzan.com design MATCHINFO