Home Are scopes supported in Wordpress OAuth 2 implementation
Reply: 0

Are scopes supported in Wordpress OAuth 2 implementation

d0kt0r1
1#
d0kt0r1 Published in 2018-02-14 10:10:37Z

I installed the https://github.com/WP-API/OAuth2 OAuth 2 plugin from the Wordpress Team.

However, whenever I try to get "edit" scope like this: http://somehostname.com/wp-login.php?action=oauth2_authorize&client_id=someclientid&response_type=code&redirect_uri=http%3A%2F%2Flocalhost%3A33333&scope=edit

nothing changes, because whenever I try to insert/edit a post I get the following error:

{"code":"rest_cannot_create","message":"Sorry, you are not allowed to create posts as this user.","data":{"status":401}}
You need to login account before you can post.

About| Privacy statement| Terms of Service| Advertising| Contact us| Help| Sitemap|
Processed in 0.383013 second(s) , Gzip On .

© 2016 Powered by mzan.com design MATCHINFO