Home Unknown column 'user_id' in 'field list' ox_session after logging into revive adserver
Reply: 0

Unknown column 'user_id' in 'field list' ox_session after logging into revive adserver

user4756
1#
user4756 Published in September 20, 2018, 5:08 pm

I am trying to move an install of Revive Ad Server (v 4.11 - upgraded from OpenX) to a new server. Our host has provided me with a backup of the mysql database and an archive of the files (php, etc.). I've created the database and restored the backup and copied the files into place and modified the config file to use the new database.

When I log into Revive, I receive the following error:

Unknown column 'user_id' in 'field list'

The command it's trying to execute is an update on the ox_session table and it's referring to a column called 'user_id'. However, the user_id column doesn't exist in the table. Here's the create statement I see in the mysql backup I restored:

CREATE TABLE `ox_session` (
  `sessionid` varchar(32) NOT NULL DEFAULT '',
  `sessiondata` text NOT NULL,
  `lastused` datetime DEFAULT NULL,
  PRIMARY KEY (`sessionid`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1;

Here is the desc of the table in the restored database:

+-------------+-------------+------+-----+---------+-------+
| Field       | Type        | Null | Key | Default | Extra |
+-------------+-------------+------+-----+---------+-------+
| sessionid   | varchar(32) | NO   | PRI |         |       |
| sessiondata | text        | NO   |     | NULL    |       |
| lastused    | datetime    | YES  |     | NULL    |       |
+-------------+-------------+------+-----+---------+-------+

Any ideas why Revive is looking for the user_id column that doesn't exist?

share|improve this question

1 Answer 1

active oldest votes
up vote 0 down vote
You need to login account before you can post.

About| Privacy statement| Terms of Service| Advertising| Contact us| Help| Sitemap|
Processed in 0.358519 second(s) , Gzip On .

© 2016 Powered by mzan.com design MATCHINFO