Home Kendo toolbar misbehave
Reply: 0

Kendo toolbar misbehave

user3190
1#
user3190 Published in April 26, 2018, 1:46 pm

I'm having a problem implementing a toolbar for kendo grid. The problem is a partial view used to load a left-sided menu for a specific module in the website application. So far, I have not been able to work around this, thus I'm asking here for help.

This is what the grid looks like without the left menu:

This is what the grid looks like with the left menu:

So far, this is what the menu code has:

<nav class="navbar navbar-default navbar-left" style="margin:0px; padding:0px; border-color:lightgray;">
<div class="collapse navbar-collapse" style="margin:0px; padding:0px;">
    <ul class="nav navbar-">
        @if (Request.IsAuthenticated)
        {
            <li>
                <a href="@Url.Action("Index", "FicheiroIdqa")">
                    <span class="fa fa-circle" style="font-size:8px; vertical-align:middle;"></span> Ficheiros Idqa
                </a>
            </li>
            <li>
                <a href="@Url.Action("Index", "ZaPe")">
                    <span class="fa fa-circle" style="font-size:8px; vertical-align:middle;"></span> ZaPes
                </a>
            </li>
            <li>
                <a href="@Url.Action("Index", "LocalColheita")">
                    <span class="fa fa-circle" style="font-size:8px; vertical-align:middle;"></span> Locais Colheita
                </a>
            </li>
            <li>
                <a href="@Url.Action("Index", "FamiliaParametro")">
                    <span class="fa fa-circle" style="font-size:8px; vertical-align:middle;"></span> Famílias Parâmetro
                </a>
            </li>
            <li>
                <a href="@Url.Action("", "")">
                    <span class="fa fa-circle" style="font-size:8px; vertical-align:middle;"></span> Editais
                </a>
            </li>
            <li>
                <a href="@Url.Action("Index", "Resultados")">
                    <span class="fa fa-circle" style="font-size:8px; vertical-align:middle;"></span> Export. Resultados
                </a>
            </li>
        }
    </ul>
</div>

And this is the code in the view, where I am calling the partial with the menu:

@model List<INL.InLabLimsAqua.OnlineResults.WebApp.ViewModels.FicheiroIdqaViewModel>

@{ ViewBag.Title = "Ficheiros Idqa"; }

<h5>@Html.ActionLink("Ersar", "Index", "Ersar") > @ViewBag.Title</h5>
<hr />
<div class="col-md-2" style="padding-left:0px; width:200px;">
    @Html.Partial("~/Views/Ersar/_ErsarMenu.cshtml")
</div>
<div class="col-md-offset-1" style="padding-left:95px;">
    ...
    grid configuration
    ...
</div>

I think the problem resides in the fact that the toolbar is being loaded in the same row as the left menu, and it pushes it down with its height. Any help to fix this would be much appreciated.

You need to login account before you can post.

About| Privacy statement| Terms of Service| Advertising| Contact us| Help| Sitemap|
Processed in 0.443737 second(s) , Gzip On .

© 2016 Powered by mzan.com design MATCHINFO